ORA-00942/ORA-00904/EXP-00056 with Oracle exp

Oracle export utility when used to export from a lower version of database may not work due to compatibility issues as the export utility expects a set of views that are not present in the database. Even patchset difference between the exp utility and the database can lead to similar issues.

The best bet to deal with the issue is to use the lowest version available at the source/target database.

If you are using Oracle client, opt for the lowest version available for taking the export.

The errors differ based on the version difference between exp utility and the database, the following errors are possible:

9i client against lower versions of 9i database or 10g clients against 9.2.0.4 database can cause the following messages in the export log:

EXP-00056 Oracle error 942 encountered
ORA-00942 table or view does not exist
EXP-00000 Export terminated unsuccessfully

On some 9i R2 versions, the error may be reported as below:

EXP-00008: ORACLE error 942 encountered
ORA-00942: table or view does not exist
EXP-00024: Export views not installed, please notify your DBA
EXP-00000: Export terminated unsuccessfully

9.2.0.6 export client against a 9.2.0.5 can cause the following messages in the export log during the export of partitioned tables.

EXP-00056: ORACLE error 6550 encountered
ORA-06550: line 1, column 48:
PLS-00302: component ‘CHECK_MATCH_TEMPLATE’ must be declared
ORA-06550: line 1, column 14:
PL/SQL: Statement ignored

10.2.0.4 client against a 10.2.0.3 database can cause the following messages in the export log during the export of operators.

. exporting operators
EXP-00008: ORACLE error 904 encountered
ORA-00904: “OLEVEL”: invalid identifier
EXP-00000: Export terminated unsuccessfully

Share

Leave a Reply

  

  

  

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>